Java Mac OSX 10.6 Update 12 Problem with Matlabpool?

9 views (last 30 days)
Jason
Jason on 6 Feb 2013
Answered: jacob lalaounis on 9 Jul 2015
I recently installed an automatic update for Java (yesterday). And since doing so, I am getting the following error when I attempt to run computations in parallel using matlabpool:
"??? Error using ==> matlabpool at 125 Java exception occurred: java.lang.NullPointerException at java.util.logging.Logger.demandLogger(Logger.java:286) at java.util.logging.Logger.getLogger(Logger.java:321)
Error in ==> LR_SL at 50 matlabpool open 4;"
Before installing this update to Java, I have had no problems running matlabpool in the local configuration. It seems that this error is thrown in the subroutine iVerifyJava().
I am running Matlab 2010b. I have tried running the matlabpool command in 2010a, but to no avail.
Any help would be greatly appreciated.
Thanks!

Answers (16)

Andreas Goser
Andreas Goser on 22 Feb 2013
MathWorks Development created a patch for this. It will be published soon - together with a related issue. I will post the link to this bug report and patch as soon as it is available. If the workarounds don't work for you, or you have an urgent need for the patch, please contact Technical Support and refer to this thread and they will provide the patch.
  10 Comments
Wynn
Wynn on 27 Jun 2014
Just repeating the previous requests for a 2010a fix. This is the most recent available version of 32-bit MATLAB for Mac, so I need to use this version.

Sign in to comment.


Danny
Danny on 7 Feb 2013
It seems I have the same problem.
'matlabpool' command doesn't work anymore after I've installed Mac OS X Java update yesterday.
The environment is, Mac OS X 10.6.8, Java 1.6.0_39 (build 1.6.0_39-b04-442-10M4008), Matlab 2012a and 2012b.
But I guess I managed to fix the problem.
First, start up the Matlab.
Before executing your codes (probably containing 'matlabpool' command), just run the Cluster Profile Manager'. (In the menu, 'Parallel' >> 'Manage Cluster Profiles')
Then, close the Cluster Profile Manager. You don't have to do anything in it. Just open and close.
Now, try to run your codes.
This has fixed my problem though I have no idea why it works.
Good luck.
  5 Comments
Tiago
Tiago on 15 Feb 2014
Amazing, it actually works!!! Great. Type 'prefdir', go to that folder and delete file parallel.setting. Initiate MATLAB, go to 'parallel' and 'manage cluster profiles', then close it. Matlab will create a new parallel.setting file inside prefdir folder. Then you can use parallel computing. Worked for me!! Thanks!!! Environment: MacOS 10.9.1, JAVA 1.7.0_51-b13, MATLAB 2013a. Cheeeeeeers!!!

Sign in to comment.


Andreas Goser
Andreas Goser on 7 Feb 2013
This issue was brought to the attention of MathWorks Technical Support earlier this week. This issue is reproducible and being investigated together with Development. In case you contact MathWorks Technical Support, you can refer to this thread and 'SR 1-LF8FNT'.

Thomas
Thomas on 6 Feb 2013
What java version are you at.
Open terminal and type
java -version
I tested with
java version "1.6.0_37"
Java(TM) SE Runtime Environment (build 1.6.0_37-b06-434-11M3909)
Java HotSpot(TM) 64-Bit Server VM (build 20.12-b01-434, mixed mode)
on R 2010b sp1 --- R2012b (all releases in between)
on OSX 10.7.5 and on OSX 10.6.8 and the local matlabpool works fine on both.
  2 Comments
Andi
Andi on 7 Feb 2013
Thomas, do you know if it's safe to install Java 1.6.0_37 after I've installed 0_39? Do I have to uninstall 0_39?

Sign in to comment.


Jason
Jason on 13 Feb 2013
Hi all, Glad to see there's a common audience for this. The 'trick' of validating upon startup seems to work, but this is unnecessarily cumbersome. It is a downgrade, rather than an upgrade.
Mathworks people, do you have an automated work-around for this? Perhaps a way to run the validation upon startup? Even still, this is time-consuming for launching Matlab so a proper fix for this Java incompatibility would be best. Please update on when this will be happening.
  1 Comment
Andreas Goser
Andreas Goser on 18 Feb 2013
Development is working on this. I will keep you updated.

Sign in to comment.


Hiroki
Hiroki on 7 Feb 2013
I am also getting the same error on OSX 10.6.8. Java for Mac OSX 10.6 Update 12 came with:
java version "1.6.0_39"
Java(TM) SE Runtime Environment (build 1.6.0_39-b04-442-10M4008)
Java HotSpot(TM) 64-Bit Server VM (build 20.14-b01-442, mixed mode)

Thomas
Thomas on 8 Feb 2013
I have the latest version of Java and had no luck until uninstalling R2011B and updating to R2012B. At this point, I had to run a validation before the system ran correctly. FYI

Reynaldo
Reynaldo on 22 Feb 2013
Edited: Reynaldo on 22 Feb 2013
The trick Danny proposed works for me too. I am using 1.6.0_41. Please notify us as soon as a fix is found!

Jason
Jason on 22 Feb 2013
Thanks, all, for responding on this. But is there any way to have the parallel work without having to run validation manually upon startup??
  1 Comment
Jason Ross
Jason Ross on 22 Feb 2013
See Andreas' response above -- a patch is in the works, or you can contact Technical Support directly.

Sign in to comment.


Jon
Jon on 25 Mar 2013
I just did everything as explained above, updated toolbox cache in the preferences and tried matlabpool and got:
Error using matlabpool (line 134) Undefined function 'distcomp.fileserializer' for input arguments of type 'distcomp.filestorage'.
I cannot find this file anywhere. Any ideas?
Best Jon

Ferenc
Ferenc on 25 Mar 2013
Hello,
I am getting these errors with Matlab 2013a on OS X 10.8.2.
>> matlabpool
Error using matlabpool (line 134)
Java exception occurred:
java.lang.NullPointerException
at java.util.logging.Logger.demandLogger(Logger.java:286)
at java.util.logging.Logger.getLogger(Logger.java:321)
>> matlabpool
Starting matlabpool using the 'local' profile ... Warning: an error occurred while parsing class distcomp.fileserializer:
Attempt to reference field of non-structure array.
> In distcomp.filestorage.filestorage at 49
In CJSCluster>CJSCluster.CJSCluster at 487
In Local.Local>Local.Local at 302
In parcluster at 51
In ProfileConfigHelper>ProfileConfigHelper.buildScheduler at 76
In MatlabpoolHelper>MatlabpoolHelper.parseMatlabpoolInputs at 290
In MatlabpoolHelper>MatlabpoolHelper.parseInputsAndCheckOutputsForFunction at 100
In matlabpool at 130
Error using matlabpool (line 134)
Undefined function 'distcomp.fileserializer' for input arguments of type
'distcomp.filestorage'.
>> matlabpool
Starting matlabpool using the 'local' profile ...
Error using matlabpool (line 134)
Undefined function 'distcomp.fileserializer' for input arguments of type
'distcomp.filestorage'.
Can anyone help?
Thanks, Ferenc

Koji
Koji on 14 May 2013
Hi,
I am trying to work on Distributed Computing Toolbox 3.2 (R2007b) installed on OSX 10.8.3, and I think I am having a similar JVM problem:
-------------
>> matlabpool
??? Undefined function or variable 'distcomp.interactiveclient'.
Error in ==> matlabpool at 82
client = distcomp.getInteractiveObject();
>>
-------
I know a bug report is here:
but a patch for R2007b looks remaining undeveloped.
Can anyone help me?
Best wishes,
Koji
  2 Comments
Koji
Koji on 14 May 2013
Hi Tom,
Thank you for your suggestions. Do you have a recommendation for a version of JVM? My OSX currently has 1.6.0_45.
Thanks again,
Koji

Sign in to comment.


Joost
Joost on 29 May 2013
Matlab 2013a generates a series of java errors when attempting to open the editor. This is what I get:
java.lang.NullPointerException at sun.reflect.UnsafeFieldAccessorImpl.ensureObj(UnsafeFieldAccessorImpl.java:36) at sun.reflect.UnsafeObjectFieldAccessorImpl.get(UnsafeObjectFieldAccessorImpl.java:18) at java.lang.reflect.Field.get(Field.java:358) at apple.awt.CAccessibility.getAccessibleRoleFor(CAccessibility.java:200) at apple.awt.CAccessibility$11.call(CAccessibility.java:215) at apple.awt.CAccessibility$11.call(CAccessibility.java:212) at apple.awt.CToolkit$CallableWrapper.run(CToolkit.java:1125) at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:199) at apple.awt.CToolkit$CPeerEvent.dispatch(CToolkit.java:1215) at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:708) at java.awt.EventQueue.access$400(EventQueue.java:82) at java.awt.EventQueue$2.run(EventQueue.java:669) at java.awt.EventQueue$2.run(EventQueue.java:667) at java.security.AccessController.doPrivileged(Native Method) at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:87) at java.awt.EventQueue.dispatchEvent(EventQueue.java:678) at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:296) at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:211) at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:201) at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:196) at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:188) at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)
As a result, I can no longer use Matlab. I have removed matlab entirely and reinstalled it without effect. I have applied the fix mentioned above, no positive result.
Hopefully someone can help because I am dead in the water right now.
I am using java 7 update 21, OSX 10.8.3

GradStudent
GradStudent on 12 Feb 2014
Edited: GradStudent on 12 Feb 2014
Just open the cluster manager, allow it to (automatically) create a local cluster, and then run the verification tests. More info here: http://www.mathworks.com/help/distcomp/clusters-and-cluster-profiles.html
I applied the patch, and Matlab wouldn't open (Mac OS 10.8.5, java version "1.6.0_65" - java 7, update 51). Only deleting matlab and reinstalling it fixed the problem (I had no indication what the problem was).
  2 Comments

Sign in to comment.


Brian
Brian on 15 May 2014
Can't use matlabpool too on Mac OS 10.9.2, R2013a student version, with :
java version "1.6.0_65"
Java(TM) SE Runtime Environment (build 1.6.0_65-b14-462-11M4609)
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-462, mixed mode)
The trick proposed By Blake worked once but now i'm getting several errors when I try to use matlabpool or even when I just open the cluster manager. I also tried the patch but it didn't fix the problem.
Since I updated java I have many problems. For instance, I can't open matlab through the spotlight, I have to use the sudo sh command in the terminal!
Should I try to reinstall an older version of java ?
  1 Comment
Radwa
Radwa on 7 Jan 2015
I have R2012a and MAC 10.6.8 I upgrade java to update 17 , and matlab didn't open should I downgrade it?

Sign in to comment.


jacob lalaounis
jacob lalaounis on 9 Jul 2015
Hi all,
I used this http://www.mathworks.com/support/bugreports/919688 and now Matlab does not work, i am using Matlab 2012.a on Mac OSX 10.9.5
If you have find a solution, it would be great to share, thank you in advance, Jacob

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!