MATLAB Answers

Error using matlab.cod​etools.req​uiredFiles​AndProduct​s (line 91)

6 views (last 30 days)
Bereketab Gulai
Bereketab Gulai on 22 Apr 2020
Commented: Bereketab Gulai on 22 Apr 2020
Hello,
Here is an error with checking required products. This worked fine previously but not now.
[fList,pList] = matlab.codetools.requiredFilesAndProducts('test.mlapp');
Error using matlab.codetools.requiredFilesAndProducts (line 91)
Simulink is not avaiable.
First time this happened while trying to compile:
Log error details:
Error while determining required deployable files. Compilation terminated. Details:
Error using <a href="matlab:matlab.internal.language.introspective.errorDocCallback('matlab.depfun.internal.SimulinkModelInspector', 'C:\Program Files\MATLAB\R2019b\toolbox\matlab\depfun\+matlab\+depfun\+internal\SimulinkModelInspector.m', 11)" style="font-weight:bold">matlab.depfun.internal.SimulinkModelInspector</a> (<a href="matlab: opentoline('C:\Program Files\MATLAB\R2019b\toolbox\matlab\depfun\+matlab\+depfun\+internal\SimulinkModelInspector.m',11,0)">line 11</a>)
Simulink is not avaiable.
mcc failed.
license('inuse') shows, but I am not sure what was it before.
matlab
I tried other version R2018b and R2019a. They are working fine with same license but I need R2019b version.
I tried signing out (Win 10) and restarting MATLAB R2019b. Same problem still there. This is with any app, not one that uses Simulink...
  • What is the solution for R2019b?

  0 Comments

Sign in to comment.

Answers (1)

Sean de Wolski
Sean de Wolski on 22 Apr 2020
Please contact technical support. At the very least this is a bug because available has a typo in it.

  1 Comment

Bereketab Gulai
Bereketab Gulai on 22 Apr 2020
Okay, I have posted as bug into the service request..
  • But work around would be great for now?

Sign in to comment.

Products


Release

R2019b