MATLAB Answers

Support package for deep learning not working in compiled program

7 views (last 30 days)
Josh
Josh on 19 Mar 2020
Answered: Steven Lord on 9 Jul 2020
Hi,
I'm using deploytool to create an executable for a script that creates a deep learning model from images. It's based upon the vgg16 model, and when run from matlab, works fine as vgg16.mlpkginstall has been run and the package installed. When compiling my program I include this:
But the program still runs into an error when looking for vgg16:
Any help here would be greatly appreciated, thank you.

  1 Comment

Josh
Josh on 20 Mar 2020
Sorry just wanted to bump this as it's buried with no views. Hope that's not against the rules.

Sign in to comment.

Answers (2)

Bhargavi Maganuru
Bhargavi Maganuru on 9 Jul 2020
Hi,
Makesure you install support package from Add-on Explorer.
Type vgg16 at the command line.
If Deep Learning Toolbox Model for VGG-16 Network support package is not installed, then the function provides a link to the required support package in the Add-On Explorer. To install the support package, click the link, and then click Install. Check that the installation is successful by typing vgg16 at the command line.

  0 Comments

Sign in to comment.


Steven Lord
Steven Lord on 9 Jul 2020
How are you creating the VGG-16 network in your standalone application? If you're calling load on a MAT-file to read the object into the workspace see this documentation page for how to handle the MAT-file and the Tip in the section "Fixing Callback Problems: Missing Functions" on this documentation page for how to ensure the definition of the class that will be created when you load the data is included in the application.

  0 Comments

Sign in to comment.

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!