MATLAB Answers

JRE Error with R2020a and Matlab_Runtime

14 views (last 30 days)
Jonas M.
Jonas M. on 24 Sep 2020
Commented: Maeda Noriko on 19 May 2021
Hi everyone,
I have some problems with a compiled Matlab GUI. In R2019b everything was working fine. Since updating to R2020a I have some problems. The compiling works fine, only afterward when I am testing (with the same machine), I get a Java error when I run the installer_mcr file. I work on Ubuntu 18.04. I checked my JDK version already and I think it is correct.
This is a part of the error message. I am happy for every help, thanks.
# A fatal error has been detected by the Java Runtime Environment:
#
# SIGSEGV (0xb) at pc=0x00007fed565c0b18, pid=2635, tid=0x00007fed2c4d1700
#
# JRE version: Java(TM) SE Runtime Environment (8.0_202-b08) (build 1.8.0_202-b08)
# Java VM: Java HotSpot(TM) 64-Bit Server VM (25.202-b08 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C [ld-linux-x86-64.so.2+0xcb18]
#
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
I tried ulimit -c unlimited already. This was not helping unfortunately. This is my java version:
openjdk version "1.8.0_265"
OpenJDK Runtime Environment (build 1.8.0_265-8u265-b01-0ubuntu2~18.04-b01)
OpenJDK 64-Bit Server VM (build 25.265-b01, mixed mode)
  2 Comments
Maeda Noriko
Maeda Noriko on 19 May 2021
same problem here. could you tell me more detail how you solved this problem. What's silent installation mode?

Sign in to comment.

Answers (0)

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!