MATLAB Answers

C2000 SCI Communication: Always Timeouts?

3 views (last 30 days)
Hi all! ;)
I am trying to establish serial communication between my computer and my F28069M-LaunchPad via USB cable. My aim is to set certain parameters of a 3-phase inverter (like switching frequency etc.) via SCI blocks on my host computer and send them to the MCU via USB connection. Furthermore, I want to read data from the inverter (like rotor speed, torque, voltages, currents etc.) and to display these values on Simulink scopes on my host computer. My aim is to achieve a communication like the one shown in this MathWorks tutorial: https://youtu.be/wxYTLbYfBP0?t=2m For this purpose I created two models: 1.) One model which is built and run on the MCU and contains an "SCI Transmit" block. 2.) One model that is executed on my host computer after successfully building and beginning to run the other model on the MCU. This model contains an "SCI Setup" block, an "SCI Receive" block and a Simulink scope. I am using the following settings in both of the models: I chose COM4 as the port for serial communication which is the COM-port of "TI XDS100 Channel B". This port is also shown in the device manager and the bitrate set in the device manager (115200) matches the baudrate I set in the settings of my Simulink models (also 115200). So I think I took care of all settings to achieve a communication via SCI. But when model 1 is running on the MCU and I start running model 2 on my host computer, the "SCI Receive" block only returns timeouts. I see the default output for timeouts (which I specified in my "SCI Receive" block) on the scope and the timeout is also displayed in the Diagnostic Viewer. What could be the reason that the host computer only receives timeouts? Have I forgotten some settings? For example, I do not know what "loopback mode" means and I deactivated it. Or do I have to take care about some jumper configurations or positions of the three switches on my LaunchPad?
Best regards, Armin

Accepted Answer

Armin Lensker
Armin Lensker on 7 Aug 2017
The solution to my problem was posted in the forum I linked in the comment to my question.

More Answers (0)

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!