Simulink crash in Ubuntu 20.04

239 views (last 30 days)
vishwas jain
vishwas jain on 19 Oct 2021
Answered: Love Sehra about 3 hours ago
I have Ubuntu 20.04 and installed MATLAB 2021b. When I run (does not matter whether or not as root) simulink, it crashes with the error "Inconsistency detected by ld.so: ../elf/dl-tls.c: 517: _dl_allocate_tls_init: Assertion `listp != NULL' failed!".
Here it says, the problem is with glibc version and it is suggested that version should be changed. But changing the glibc version may create problem within the OS.
Are there any other solutions?
System Info:
Kernel: 5.11.0-37-generic
gcc: 9.3.0
glibc: 2.31

Answers (3)

Yongjian Feng
Yongjian Feng on 28 Oct 2021
Have you tried this approach:
Installed a local copy of glibc of the recommended version. A local copy is not used by your OS, so you don't need to worry.
Now from a terminal, change your env var LD_LIBRARAY_PATH by inserting the local path as the FIRST. Start matlab from this terminal. This will force matlab to use the local glibc.
  2 Comments
Yongjian Feng
Yongjian Feng on 8 Nov 2021
No. Two steps here.
  1. Set LD_LIBRARY_PATH. You need to put your local glibc folder as the first one to force matlab to use it. In a terminal: export LD_LIBRARY_PATH=your_local_glibc_path:$LD_LIBRARY_PATH
  2. Then from the same terminal, go to the installation folder of your matlab. Most likely is /usr/local/Matlab<release>. Then type bin/matlab&

Sign in to comment.


Anton Hristozov
Anton Hristozov on 3 Dec 2021 at 17:47
Edited: Anton Hristozov on 3 Dec 2021 at 17:48
This is very disappointing to see in ofiicially supported Ubuntu 20.04 distribution.
There is no other application that needs to downgrade something as used as libc lib.

Love Sehra
Love Sehra about 3 hours ago
These are the error messages when I open simulink on Matlab R2021a on my Ubuntu 20.04. I recently installed both the OS and MATLAB.
error1error2
SlProxy service unavailable.
and
Error loading /usr/local/MATLAB/R2021a/bin/glnxa64/builtins/sl_main/mwlibmwsimulink_builtinimpl.so. /usr/local/MATLAB/R2021a/bin/glnxa64/builtins/sl_main/../../../../bin/glnxa64/libmwsl_prm_engine.so: undefined symbol: _Z27FcnCheckAndConvParamToFixPtPK7SLBlockP21_slDataTypeAccess_tagPKvPKclibiPv: Resource temporarily unavailable: Resource temporarily unavailable
I have searched for them online, but couldn't find anything helpful.
Additionally, when I dismiss these messages and try to create a new blank model, I get another error:
error3
Error loading /usr/local/MATLAB/R2021a/bin/glnxa64/builtins/sl_main/mwlibmwsimulink_builtinimpl.so. /usr/local/MATLAB/R2021a/bin/glnxa64/builtins/sl_main/../../../../bin/glnxa64/libmwsl_prm_engine.so: undefined symbol: _Z27FcnCheckAndConvParamToFixPtPK7SLBlockP21_slDataTypeAccess_tagPKvPKclibiPv: No such file or directory: No such file or directory
I solved it installing an update from the notifications icon of the Matlab home page. Restarting Matlab, now Simulink works successfully.

Products


Release

R2021b

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!